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  Document outline 

About the drawing protocol document 

Chhattisgarh Municipal Corporation has planned to automate the building plan approval 

process by introducing the AutoDCR system. AutoDCR software reads the CAD drawings 

submitted by architects and automatically produces the deviation report based on the control 

regulations prescribed by CHIPS.  

The purpose of this document is to establish a set of guidelines to Architects for preparation of 

drawings to be submitted for taking Building Permission from CHIPS, Uniformity in the process 

of drafting of the drawings to be submitted for approval is required for automation of building 

approval system by introducing AutoDCR system.  

The consultants/Architects should prepare the drawings keeping specific objects in specific 

layers with specific colors and text.  The layers required to be generated with explanation of 

what is required to be drawn on which layer is described in this document. This document 

serves as a source of information on obtaining level of consistency in drafting and approval 

process focuses on both the theoretical and practical description of process flow and protocol to 

be used while preparing drawings for submission at CHIPS for Building Permission. The 

document explains use of PreDCR utility.  

 

 How to read this drawing protocol document? 

This document should be read in conjunction with the building byelaws, which will be 

applicable for approval of a proposal.  The reader of this document should have understood the 

applicable byelaws for scrutiny of a proposal. The reader should also be familiar with AutoCAD 

terminology and environment for better understanding of the system. It is more exploratory in 

nature than the specifications and contains sections to explain particular aspect of planning and 

designing. 
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Drawing pre-formatting utility (PreDCR) 
 

Overview 

AutoDCR is a unique and innovative approach to automate scrutiny of building proposals by 

reading CAD drawings. AutoDCR software needs preformatted drawings with some 

specifications. PreDCR is a software application used to create the architectural plan as per 

AutoDCR software requirements. It helps in standardization of drawings and helps in reducing 

time required for preparing submission drawings. It works under AutoCAD environment with 

additional menu & toolbar. 

 
Using PreDCR commands user can create all the required layers in one click. Once all the layers 

are created in the drawing user can use AutoCAD commands to draw entities on the 

corresponding layers with the help of PreDCR software. Short commands are provided to 

activate any layer in PreDCR. PreDCR also helps in correcting drafting errors in the drawing. At 

any time, user can verify if the drawn entities are properly closed or not, if proper name text has 

been written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 
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Aims & objectives 

To bring uniformity and standardization in submission drawing format. 

To create error-free drawing by auto-correction of drafting errors. 

To Increase drafting speed and efficiency 

To reduce drawing data redundancy. 

To remove dimensioning and area calculation requirements from submission drawing format 

and auto-calculating areas in AutoDCR automatically.  

Salient features 

Automatically creating required layers in the drawing 

 

Automatically creating and inserting entites of required size in the drawing: User can define size 

of entity and insertion point in the the drawing.PreDCR will create and insert entity in the 

drawing at specified location. 
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Automatic insertion of required text in the drawing. 

 

Drawing cleaning, refinements of poly lines, text and closed entity verification will be done by 

PreDCR to eliminate drafting errors. 
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PreDCR verify and will highlight failed entities in verifications with detailed explanation and 

Auto-zooming. 
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Benefits of PreDCR 

1) Standardization of submission drawings-Brings uniformity & standardization in submission 

drawing format. This software will correct some minor drafting errors and provide list of failed 

entities with Auto-zooming facility so that user can easily locate the failed entities in the 

drawing.  

2) Operational ease and convenience-Data redundancy is eliminated from the drawing. Only 

minimum required entities are to be drawn in the drawing, as most of the data will be auto 

detected by the system from existing available data. 

3) Increased speed and efficiency-PreDCR facilitates Auto insertion of many drawing entities 

like parking, door windows etc. of required size and number. Test auto-insertion facility saves 

text-typing efforts. Auto-dimensioning and auto-calculation facility saves calculation efforts. 

Using this software user can create all the required layers at one click.    

4) Accuracy - Accuracy in area calculations is achieved. Preparing Calculation tables, showing 

dimensions in the drawing is not required.  
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Drawing formats 

 

1) Conventional submission drawing format  

 

 

2) As per PreDCR format specified by PreDCR  

 

Conventional drawing submission format 
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3) After scrutiny of drawing using AutoDCR- 

 

Protocol details 

 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It works under AutoCAD environment with additional menu & toolbar. 

           Using PreDCR commands user can create all the required layers in one click. Once all the 

layers are created in the drawing user can use AutoCAD commands to draw layout plan. 

As per AutoDCR requirement all building items like proposed Plot Boundary, proposed work 

should be drawn on the corresponding layers. Short commands are provided to activate any 

layer in PreDCR  

At any time user can verify if the drawn entities are properly closed or not, if proper name text  

has been written inside all closed poly or not etc. PreDCR will highlight all the failed entities if 

any. 

          PreDCR can be used to modify/make and verify the existing or new architectural plan as 

per AutoDCR software requirements. Users are free to use AutoCAD commands and or PreDCR 

commands to achieve the main purpose which is:  
Drawing the architectural plan in DWG format as per AutoDCR software requirements. 
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For automating the process of Development Control Regulations user/draughtsman/architect 

have to follow some specifications. The following are the list of specifications that the user 

should follow.  

Plot Boundary layout, detailed floor plan and building section for all the floors should be there 

in one AutoCAD drawing file.   

All building items like proposed Plot Boundary, proposed work, proposed parking etc. must be 

drawn using closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, Dead Wall and Ground level.).  

Building Sub-Items must be exactly inside of outer closed polygon as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container 

entity.  

       For example, Parking or Open Space poly must be exactly inside the main Plot Boundary 

poly. 

       Tools are provided in PreDCR to verify this check.  
Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the same 

layer & inside the entity poly. If name not found, then AutoDCR will generate the name 

automatically. Naming Conventions should be followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 

Living, Kitchen, and Bedroom...Etc.  

Floor Name: GROUND FLOOR; TYPICAL FLOOR 1, 2 & 5-8; TERRACE FLOOR 

Floor Items: Room Names should be given properly without using abbreviations so the 

software can identify perfect entity. This can be done by Assign name facility provided by the 

software. 

User shall use only following kind of entities for Building Items: -  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plans for each proposed work. 
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Installation and Registration 

System Requirements  

• Pentium IV or better (or compatible processor) 

• 4 GB RAM  

• Windows 98/2000/ 2007/XP Vista & Windows 7, 8 & 10 {32 bit & 64 bit} 

• CD-ROM drive 

• AutoCAD 2000 and onwards 

 

Installation 

 

To install PreDCR software on your computer please follow the given steps.  

Step 1:  Download PreDCR from the Corporation Website. 

Step 2:  Run the PreDCR installer by double clicking on file "PreDCR_Installer.exe"  

 

Step 3:  Follow the next steps in installer wizard to complete installation.  

After successful installation, a PreDCR shortcut will be placed on your computer desktop as  

shown below. 
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Figure 1: PreDCR shortcut on desktop 

Registering and running PreDCR 

To run PreDCR software follow the given steps. 

 

Step 1: Double click or right click on PreDCR icon and select open menu.  

In Fig 1.You can also run it from Start-->Programs-->SEPL->PreDCR 

 

Step 2: PreDCR will start under AutoCAD-2000 & onward versions and ask to register the 

software if you have taken the “Soft Lock Set of PreDCR”. 

 Step 3: Click on Register button to register PreDCR. You will see registration form with 

Reference code and key as shown below in Figure 2. 
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Figure 2: PreDCR Registration form 
 Step 4: Now you have to send this Reference Code generated on your computer to given  

            email address support_dcr@softTech-engr.com or contact  

            SoftTech Engineers Ltd. on Phone:    2421-7676 / 2421-8747                                              
Against that reference code you can get the Key from our office which you have to enter in the blank space 

provided. 
Note: From next time PreDCR will start directly until you format your computer. 

Methodology  
1)   Open the PreDCR software for clicking on PreDCR menu on your desktop & select the 

AutoCAD version & then click on "OK" button. 

mailto:support_dcr@softTech-engr.comm
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2)  First open test drawing, which is now converting in PreDCR format. 
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3)  Save as your drawing with give some name. 

 
 

4) Check the scale by using Scale command. If drawing is not in 1: 100 scale, then covert into the 
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1:100 scale. & then make that drawing in matric scale if it is in other than meter.  

 
 

5) Also make the site plan in 1:100 scale. 

 
6)  By using PreDCR toolbar first select the Type of Project that is " Proposed Development“ , 
“Land Division” or “Plot Boundary ting Layout”  
a) If Plot Boundary  is Already sanctioned & user have to take permission for the buildings only 
then select “Proposed Development.” 
b) If User having Proposal is Amalgamation or Subdivision then select “Land Division” option 
from the list. 
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c) If Proposal having a Plot Boundary ting Layout then select that “Plot Boundary ting Layout” 
option from the list. 

 
 

7)  By using PreDCR toolbar "Create a DCR layer" that is second option in PreDCR toolbar. 

 
  

 
8)  Then you will get the list of PreDCR toolbar, then just click on "OK" button. Now all the 

Layers you will get in Layer Properties managers. 

 
 

 

Now Select current Layer is "_ Plot Boundary” & Draw a closed polyline on this layer. Also give 
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the Plot Boundary name on that layer only. 

 

 
Make the current layer '_Main Road” & Draw a road on this layer. Give the Name of road which 

is starting with its width. 

 

 
Make the current Layer " …….FAR" as per your project having that use you can select that use of 
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FAR. E.g. for Residential use - Select “_ResiFAR” poly, For Commercial use select “CommFAR” 

poly. & Draw an area key plan line on this layer. No need to give any name on this Layer 

 
Make the current Layer "_Carpet Area" and draw a closed poly on this Layer which having floor 

area excluding wall area. Also give the name on this Layer. If carpet is splitted no of places but 

having only one tenement then use the splitted tenement option from PreDCR Mark menu bar.     

 
Make the current Layer "_Room" and draw a closed poly on this layer. If room having rectangle 
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shape, then you can use rectangle also. Assign the room name for using the assigned name 

option from PreDCR menu bar. 

 

 
: Insert the doors & windows by using insert option from PreDCR menu bar.  

 

 
15)  Make the current layer "_Floor" and draw a boundary outside of each & every floor. 
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16)  Make the current layer "_Tank" and draw U/G & O/H tank in plan as well as in section. 

Assigned this tank name by using Assigned name option from PreDCR menu bar. 

 
17) Make the current layer "_Staircase" and draw all the riser on this layer which is an open 
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polyline. Also draw two extra line on this layer which is showing a floor landing and 

intermediate landing. Then mark this landing for using staircase landing option from PreDCR 

menu. Also mark the staircase which having type. For spiral and fabricated staircase no need to 

draw riser & landing marking. 

 
 

 18)  Make the current layer is "_Ground Level" and draw an open polyline on this layer which 

is place below the plinth level. 

 
Make the current layer is "_Building" and draw a boundary on this layer which is having a 
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group of all the floors with section 

 
 

 

 

 

 

 

 

 

 

 

 

Make the current layer is "_ProposedWork" and draw a total coverage on this layer. Assigned 
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this proposed work by using "PreDCR->Assigned name -> Building & proposed work from 

PreDCR menu. 

 

 
If project having any Substructure, then draw a closed polyline on "_Substructure" layer. Also 

mark this substructure by using “PreDCR-> Mark-> Substructure from PreDCR menu bar. 

 

 
 

 

If project having any Existing structure, then draw a closed polyline on "_Exstructure" layer. 
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Also mark this Exstructure by using “PreDCR-> Mark-> Exstructure from PreDCR menu bar. 

 

 
 

Mark the margins by using Mark-> margin from PreDCR menu bar 

 
 

After converting all the Layers, use the "Fix poly" option from PreDCR menu bar.  

 
 



 

  PreDCR help manual: Town and Country Planning Chhattisgarh  

34 Methodology 

 
 

 
 

Just click on "OK" 

 
Just click on "OK" 

 
 

When you will get this message "Refinement of Polyline is done" then select the "Verify Closed 

poly" option from PreDCR menu. 
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:  When you will get these message "Entities on PreDCR Layers are verified and found o.k." then 

only you can submit a softcopy of your drawing to the Corporation. 

 



 

  PreDCR help manual: Town and Country Planning Chhattisgarh  

36 Methodology 

 

 
 

27) Also check the "Objection list" which user are missing to convert in PreDCR layer. 
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PreDCR Layer Information 

_Amenity  

Description : 

 Draw Amenity space as a closed polyline, which is reserve for utilities, services and 

conveniences. 

 

Shortcut Command : AMN 

 

How to draw : 
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 _ArchProj 

Description :  

- This layer is used to represent various Architectural Projections in your Plan. Draw a closed 

Polyline for Architectural Projections, and mark it using Mark->Projection from PreDCR menu, 

according to requirements. Canopy/porch will come in Plot Boundary & other projections will come 

with floor plans. 

Shortcut Command:-  AP 

 

How to draw : -  
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 _Balcony 

Description :  

Draw a balcony as a closed polyline which is a horizontal projection including parapet to serve as a 

sitting out place. Name of balcony must be inside and on _Balcony layer. 

Shortcut Command : BL  

How to draw : -   

_Balcony:-                          

 

The balcony can be present in: 

 
Plot: It must overlap with Pwork (if not enclosed) 

Floor: It must overlap ResiFAR. 
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 _Building 

Description : 

Building is used to group all floor plans of the same building.   Draw a closed poly enclosing all the 
floor plans and section of the same building on _Building layer. Note: As written above, dimension or 
area of this building poly has no meaning in AutoDCR. This is just a logical group of all floors of the 
same building. If the building plan of multiple PWorks or wings are same, then building name shall 
be as given in table below. 

Building names can be. 

1  "A(Monarch)" Pwork "A" has building plan "Monarch". 

2  "A,B(Monarch)" or "A&B(Monarch)" Wings A, B have same building plan "Monarch". 

3  "A-C(Monarch)" Wings A, B, C have same building plan 

"Monarch". 

4  "A1-A3(Monarch)" Wings A1, A2, A3 have same building plan 

"Monarch". 

Shortcut Command : BLD 

How to draw : 
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_Carpet area 

Description :  

Draw carpet area as a closed polyline, which is a net usable floor area within a building excluding 

that covered by the walls, or any other areas specifically exempted from floor space index 

computation in these regulations. 

Shortcut command : CPT 

How to draw : -  
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 _Chowk 

Description :  

Draw a Chowk as a closed polyline, which is an enclosed space permanently open to the sky within a 

building at any level. From Chowk we take ventilation for habitual rooms. 

Shortcut Command : CWK 

How to draw : 
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_Column 
Description :  

Column shall be drawn as closed polyline on this layer. 

Shortcut Command : COL 
How to draw: - 

 

_CommFAR 

Description: 

Draw a CommFAR as a closed polyline, which is the area covered by a building on all the floors. 
This FAR polyline mainly used for commercial use bldg. 

Shortcut Command :CMFS 

   How to draw: 
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 _CompoundWall 

Description :  

Open polyline of compound wall to be drawn on proposed compound wall with text started with 

compound wall height. E.g. 1.5m. High Compound Wall 

Shortcut Command : CW 

How to draw : -  

 

_Door 
Description :  

Door is a closed Polyline, which is drawn on “_Door” layer. Besides, you can insert a particular size 
poly for Door using Insert->Door from PreDCR menu. 

Shortcut Command : DR 
How to draw : - 
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 _ElecticLine 

Description : - 

 Electric line will be present in the layout plan and shall pass through Plot Boundary entity as a non-

closed polyline. Name electric line shall start with its voltage capacity and text insertion point shall 

lie on its polyline. E.g. 33 KV High Tension Line. 

Shortcut Command : LI 

How to draw : - 
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 _Elevation  
Description :  

Elevation to be drawn in _Elevation layer only for printing purpose. No regulations will be 
checked by reading this layer. The drawing on this layer need not be drawn using polylines.  

Shortcut Command : EL 
How to draw:- 

 

_ExStructure 

Description: - Draw an Exstructure as a closed polyline, which is a building, or structure existing 
authorized before the commencement of these regulation. And mark it using Mark -> Existing 
structure as 'To be demolished' or 'to be retained’. 

Shortcut Command : EX 
How to draw :- 
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_EWS 

Description: -  

Draw a EWS area on “_EWS” as a closed poly line, which area is left for economically weaker 
section.  
How to draw :- 

Draw a closed poly line on _EWS layer in floor plan. 

 _Floor 

Discription: 

Draw a Floor as a closed polyline to the boundary of the lower surface in a story on which one 

normally walk in a building and including mezzanine floor. The floor at ground level with a direct 

access to a street or open space shall be called the ground floor. The floor above it shall be termed as 

Floor 1 with the next higher floor being termed as Floor 2 and so on upward. For giving the name of 

each floor use the assign named option from the PreDCR menu. Also, draw each floor separately. 

While giving name to the typical floor then use a typical option from Assigned name -> Floor name 

option from PreDCR menu bar. 

Shortcut Command : FLR 

Reference Circle: - All Floor poly must contain a circle with its center on common point for whole 

building on layer "_ResiFAR". Usually it can be placed inside either Common Lift or stair/Inner 

Chowk, as their locations are common for all floors. 

Floor Name: - Floor name will be taken from text inside floor poly and on same layer. 

  A floor plan is automatically associated/linked by AutoDCR software with one or more floor section 

poly in Section plan. This is done by matching name of Floor Plan and Floor  In Section so both must 

be same. 
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Typical Floor Non-Typical 

"TYPICAL" X "FLOOR PLAN"X: Floor 

numbers in specific format (, or & or -) 

X "FLOOR PLAN" 

X: Direct Floor's Name 

e.g.: 

TYPICAL 1,2 FLOOR PLAN 

TYPICAL 1-4 FLOOR PLAN 

TYPICAL 2&3 FLOOR PLAN 

e.g. 

GROUND FLOOR PLAN 

FIRST FLOOR PLAN 

SECOND FLOOR PLAN 

 

How to draw :- 
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 FloorInSection :  
 

Description :  
Draw a FloorInSection polyline as a closed poly of section boundary, which contain all floors with 

stair cabin, Lift machine room, water tanks etc. as shown in the figure. Also, write the name as 

"Section" in this section poly. 

In this closed poly of section, draw sections of all floors with stair cabin, inner Chowk, Lift machine 

room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also, write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw : - 

 

 _GroundLevel 

Description :  

Draw the Ground level line as open polyline in section .It is used for checking a total building height 

from this line. 



 

  PreDCR help manual: Town and Country Planning Chhattisgarh  

50 PreDCR Layer Information 

Shortcut Command : GL  

How to draw : - 

 

_IndFAR 

Description :  

 Draw an IndFAR as a closed polyline (area key plan line in the submission drawing) which is the 

area covered by all the floors. Industrial building means building or part thereof wherein products or 

material are fabricated, assembled or processed such as assembly plants, laboratories, power plans, 

refineries, gas plants, mills, dairies and factories. This polyline should be excluding balcony & 

terraces area. 

Shortcut Command :IFSL  

How to draw : - 
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_IndivSubPlot 

Description :  

For plotting layout draw individual subplots having unique text on _IndivSubPlot' layer inside             

main plot.  

Shortcut Command : IP 

How to draw : - 
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_InternalRoad 

Description :  

Draw internal road with text specifying its width as shown in figure. And draw a centerline. And type 

of layer of the centerline must be centerline (Type of the Layer). 

Shortcut Command : R2 

 

How to draw : - 

 

 _LiftWell 

Description :  

Draw a Lift as a closed polyline, which is a mechanically guided car, platform or transport for 

persons and materials between two or more levels in a vertical or substantially vertical direction. If 

fire lift is provided, then use the marking of “Fire lift" option from Mark -> Lift -> Fire Lift. Fire 
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Lift means a special lift designed for the use of fire service personnel in the event of fire or other 

emergency. 

Shortcut Command : LFT  

How to draw :  

 

Layer: _LIG 

Description :  

Draw LIG area in _LIG layer as close poly line which is left for Lower Income Group. 

How to draw :  
It should be Inside of Floor or Plot. 

_Location Plan 

Description :  

Location plan if any to be drawn on this layer. This is only for reference. AutoDCR does no 

verifications for this layer so not compulsory. 
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Shortcut Command : LCP 

_MainPlot  

Description: 

 Draw a Main Plot poly as a closed polyline, which is a parcel or piece of land enclosed by definite 

boundaries. A Main Plot will contain all Proposed Works (buildings, wings), open space, Internal 

Roads, Parking etc. The overall Main Plot Entity represent a Plan, AutoDCR refers it as 'Layout Plan'. 

The overall Main Plot Entity represent a Plan, AutoDCR refer it as "Layout Plan". 

Shortcut Command: PLT 

How to draw :- 
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 _MainRoad 

Description : 

Draw a MainRoad as a closed polyline, which is abutting the Plot Boundary. On the site, that road is 

any type of road. Such as any highway, street, lane, etc. over which the public have a right of passage 

or access or have passed and had access uninterruptedly for a specified period, whether existing or 

proposed in any scheme. Road name start with its width only. 

Shortcut Command : R1 

How to draw : - 
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 _MarginLine 

Description :  

No need to draw Margin Line, just use Mark Margin tool for it. This layer is not provided for users. 

AutoDCR uses '_MarginLine' layer for its own internal use.  

 _NETPLOT  

Description :  

No need to draw NETPLOT BOUNDARY. This layer is not provided for users. AutoDCR uses 

'_NETPLOT BOUNDARY  ' layer for its own internal use. 

_NotInPossession :- 

Description :  

Plot Boundary  area which is not in possession or which is not in proposal to be drawn as a 

closed polyline on this layer. 

Shortcut Command: NIP 

How to draw : - 
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_Parking 

Description :  

Draw a parking poly as a closed polyline, which is an enclosed covered or open area sufficient in size 

to park vehicles. This closed polyline shall contain a text on same _Parking layer. This text is treated 

as name of parking. Insert the parking by using an Insert-> parking option. 

Shortcut Command : PK 

Parking Name : 

This closed polyline shall contain a text on same _Parking layer. This text is treated as name of 

parking. On this layer, you can group and insert any number of parking. 

Parking Name 

Car CP 

Scooter SC 

Cycle CY 

Loading/Unloading LD 

How to draw : - 
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_Passage 

Description :  

A closed polyline on _Passage represents a passage. It is a common passage or circulation space 

including a common entrance hall. This closed polyline contains a text. This text must be on 

"_Passage" layer. This text is treated as name of closed polyline. 

Centre Line:  

- All Passage poly must contain an Open Polyline inside that closed poly representing centerline on 

"_Passage" Layer. However, line type of centerline must be 'Center line'. 

Shortcut Command : PAS 

How to draw: - 
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Layer: _PlotSurroundingDetails 

Description :  

Show abutting details on “_PlotSurroundingDetails” layer which is around your property 
where site is going to propose. For ex. Plot no, road width, etc. 

_Podium 

Description :  

Podium shall be drawn on '_Podium' layer as a closed polyline. Podium should be inside Plot 

Boundary covering proposed works if any. 

Shortcut Command : POD 

How to draw :- 
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_PrintAdditionalDetail 

Description :  

PrintAdditionalDetail layer----apart from the layers specified by PreDCR, any other information 

which user wants to display in final approval print shall be drawn on _...this layer 

Shortcut Command : POD 

 

How to draw :- 

 

_PropWork 

Description :  

Proposed Work is a building profile/outline and shall be drawn inside Plot Boundary. All detail 

Building plans (inside building polyline) of all Pwork (inside Plot Boundary polyline) is 

associated/linked automatically by Auto-DCR by matching its name. 

  So, for proper association it is required to follow specific standard as given. 

  XY (Z) 

  X is Wing name. 

  Y is wing number. 

  Z is Building name. 
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For example, if there are four wings A1,A2 & B1,B2 in building named "Monarch" then proposed 

work  names shall be - 

  A1 (Monarch), A2 (Monarch) 

  B1 (Monarch), B2 (Monarch) 

Reference Circle: All Pwork poly must contain two circles (of any size) with its center on common 

point for whole building. First on layer of any FAR and second on Layer “_Floor”. These reference 

circles to be inserted from PreDCR -> insert-->Direction ref circles at the same location in all the 

floors as well as Pwork in Plot Boundary.  Usually they can be placed inside either Common Lift or 

Stair/Inner Chowk (because generally their location is same on all floors). Reference circles are used 

by the software for overlapping all floor plans. 

Shortcut Command:- PW 

How to draw :- 
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_Ramp 

Description :  

Draw a Ramp poly as a closed polyline in floor plans and/or Main Plot. Naming convention for ramp 

is "---m. long and ---m. high ramp-1". Give unique name to each ramp. 

Shortcut Command :- RP 

How to draw : - 

 

 

 

 

 

_RecreationalGnd 

Description :  

 Draw Recreational Ground as closed polyline reserved as recreational space on this layer. With text 

on same layer. 

Shortcut Command : OPS 

How to draw : - 
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_RefugeArea:- 

Description :  

Refuse area to be drawn in plan as a closed polyline with text on this layer. Overlapped with FAR 

layer but outside the FAR poly. 

Shortcut Command :  

How to draw :  



 

  PreDCR help manual: Town and Country Planning Chhattisgarh  

64 PreDCR Layer Information 

 

_ResiFAR 

Description : - 

Draw a ResiFAR as a closed polyline, which is the area, covered by a building on all the floors. This 

FAR polyline only used for residential use building or floor. ResiFAR poly must be inside Floor poly. 

Shortcut Command : MFS 

How to draw : - 
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_RightOfWay  

Description :  

Draw a closed polyline on “_RightOfWay” to represent a Right Of way and text inside it 

representing its width. Layer should be inside or intersecting with Plot poly 
Shortcut Command :ROW 

How to draw :  
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_RoadWidening 

Description :  

Draw a road widening polyline as a closed polyline, which the Plot Boundary area is going to the 

road, that area should be draw on this layer. It should be inside the Plot Boundary polyline. 

Shortcut Command : R5 

How to draw : - 

 

_Room 

Description :  

A closed polyline on _Room layer represents a room. This closed polyline contains a text. This text 

must be on _Room layer. Room to be marked by assigning them names using Assign Name-> room 

option from PreDCR menu. 

Shortcut Command : RU 

How to draw : - 
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_Section 

Description :  

Draw a Section polyline as a closed poly of section boundary, which contain all floors with stair 

cabin, Lift machine room, water tanks etc. as shown in the figure. Also, write the name as "Section" 

in this section poly. In this closed poly of section, draw sections of all floors with stair cabin, inner 

Chowk, Lift machine room, Ventilation shaft, water tanks etc. as shown in the figure. Also, write the 

name as "Section" in this section poly. This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw : -  
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_SectionLine 

Description:  

Draw an open polyline on “_SectionLine” layer to show a section in floor plan as well as 
in layout. 

_SewageLine 

Description: -  

  Drain Line shall be drawn as an open polyline on this layer. 

Shortcut Command : L5 

How to draw : -  
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SpecialUseFAR 

Description :- 

FAR poly for all other building uses like educational, institutional etc. except ResiFAR, CommFAR 

& IndFAR use should be drawn on this layer. 

Shortcut Command : SUF 

How to draw : - 
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 _StairCase 

Description :  

StairCase: On this layer, Each StairCase poly shall have three lines for Flight Width, Intermediate 

Landing and Floor Landing on same layer. Mark this open polyline by using Mark-> Staircase 

option from PreDCR menu. Also, draw in plan all the treads on this layer, which is an open polyline. 

This closed polyline contains a text. This text must be on _Stair layer. This text is treated as name of 

closed polyline. On this layer, Each StairCase poly shall have three lines for Flight Width, 

Intermediate Landing and Floor Landing on same layer This can be mark by tool Mark > StairCase 

> intermediate landing etc. 

Shortcut Command : STR 

How to draw : - 
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_SubStructure 

Description :  

Draw various substructures on "_Substructure" layer as a closed polyline. And mark it according to 

the requirement as Mark -> Substructure -> Society Office, from PreDCR menu. Sub-structures 

can be drawn inside Plot Boundary or in floor plans. 

Shortcut Command :  SSTR 

How to draw : - 

 

_Tank 

Description :  

A closed polyline on _Tank layer represents a water tank. Under Ground tank can be drawn in Floor 

or Layout plan. If it is drawn in Floor plan, then it should be at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Tank should be drawn as per internal size or 

dimensions. Both the tank also draws in section also. 

Tank Name: - This closed polyline contains a text and must be in given format. This can also be 

done by tool Assign Name>Tank 

Tank Name+ Type +Capacity 
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Tank Type Text 

Overhead water tank (O/H) 

Underground water 

tank 

(U/G) 

 

For e.g. 

  TANK-1 (O/H) 

  TANK-2 (U/G) 

Under Ground tank can be drawn in Floor or Layout plan. If it is drawn in Floor plan, then it should 

be at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Usually, it is drawn on StairCase poly in 

TERRACE FLOOR. 

Shortcut Command : TNK 

How to draw : - 
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_Terrace 

Description:  

Draw a Terrace as a closed polyline on _Terrace layer, which is including parapet wall. 

Terrace can be present in:  

 

 

Shortcut Command : TER 

How to draw : - 

 

_Tree 

Description :  

Trees can be shown on _Tree layer if required to be shown for plantation requirement in plot. 

Shortcut Command  : TRE 

How to draw :  

 Floor: It must be outside the ResiFAR. 
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_VentilationShaft 

Description :  

Draw Ventilation shaft/duct area as a closed Polyline with Text. Inside FAR Area on Ventilation 

Shaft Layer. Only those shafts from which ventilation for habitable room is not taken should be 

drawn on this layer. 

Shortcut Command:- VS 

How to draw :       
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 _Void 

Description : 

If the space is not Chowk, then it can be void. All ducts (where ventilation is not taken) and double 

height rooms can be drawn in void layer. 

Shortcut Command : VD 

How to draw : - 

 

_WaterLine 

Description :  

Draw a Water line as an open polyline to show Water supply. 

Shortcut Command : WL 

How to draw : - 
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_Window 

Description :  

Window is a closed Polyline, which is drawn on "_Window" layer. Also, you can insert a particular 

size poly for Window using Insert->Window from PreDCR menu. 

Shortcut Command : WND 

How to draw : -  
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Commands 

Create New Project (PDCRNWP):  

This command will Create New project for current drawing. 

Here you have to select Type of Project as  

Proposed Development. 

 

Note: It is always compulsory to add your drawing to new Project. 

 
 

Create DCR Layers (PDCRCL):  

This command will create layers required for PreDCR AutoDCR as per the Project Type, you have 

selected. 

Fix Poly (PDCRPE):  

 

Use this command once on the final drawing, which will process all the polyline on the PreDCR 

layer and remove extra vertices found on polyline. This command can be used before verifying 

the drawing using Verify commands. 
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Verify Drawing:  

This command will verify the current drawing as required by DCR specifications. 

 a) Verify Close Entities (PDCRVD): Verify that LWPOLYLINE entities on the selected layers 

are closed and contain one text. 

 
B) Verify all drawing (PDCRVT): Use this command to verify the layout and building-level 

objects in the current drawing plan.  

Major checks are as follows: 
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In the "Verify All Drawing Dialog”, you can select the layout or building objects to be checked. 

Then to view the result press OK button. PreDCR will start checking all corresponding objects in 

the currently open drawing and then display the status as OK or list of failed objects in the 

dialog as shown in Figure. Failed Object Information.  

Check if these entities are drawn as closed LWPOLYLINE. 

Name text is given to all objects. 

Entities are placed exactly inside their parent objects (container). 

Naming conventions are followed properly. 

c) Objection List (PDCROLST): This command gives the list of all minimum required entities, 

which are not there in your drawing. If all required entities found, then it gives a message that 

“minimum required entities are present in drawing”. 

 Markings 
Marking adds some extra meaning in entity. Following commands are provided to mark 

different   entities as per requirement.  

Mark-> Proposed Work -> Centrally Air-Conditioned -> If building is, containing centrally Air-

Conditioned then marked proposed work by using this menu. 

Mark-> Proposed Work -> Normal (Default) 

Mark-> Floor in Section -> Beam -> If Beam is proposed in floor in section then marked beam 

by using this menu. 

Mark-> Stair Case-> No of flight -> 3 flight 4 flight (PDCRSCFAB): Mark staircase as a no of 

flight 3-flight or 4-flight 

Mark-> Stair Case-> Staircase (Default) -> 3 flight 4 flight (PDCRSCFAB): Mark line inside 

staircase as a no of flight 3flight 4flight. 

Mark-> Stair Case-> Open Staircase -> 3 flight 4 flight (PDCRSCFAB): Mark line inside 

staircase as a no of flight 3flight 4flight. 

Mark-> Stair Case->Fire Escape Staircase: Mark line inside staircase as a fire escape staircase 

Mark-> Stair Case-> Fab /Spiral Staircase: Mark line inside staircase as a Fabricated or spiral 

staircase. 

Mark->Road widening Taken in FAR or Unmark (default) (PDCRMRVIFAR): Mark-> Road 

widening as a to be Added in FAR or Unmark (default) 
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Mark->Escalators: Mark staircase poly as Escalator. 

Mark->Intermediate Landing (PDCRMIL): Mark line inside staircase as intermediate Landing.  

Mark->Stair Case Landing->Flight Width (PDCRMFW): Mark line inside staircase as Flight 

Width. 

Mark->Stair Case Landing->Floor Landing (PDCRMFL): Mark line inside staircase as Floor 

Landing.  

Mark->Lift--> Unmark (Default) (Default) (PDCRLTP) > Mark->Lift--> Unmark (Default). 

Mark->Lift--> Hydraulic (PDCRLHTP)> Free from FAR OR Taken in FAR > Mark Lift as 

Hydraulic & it is free from FAR or taken in FAR.  

Mark->Lift--> Fire Lift (PDCRFL): Mark Lift as fire if fire lift is provided. 

Mark->Ramp--> Ramp for Handicap: Mark Ramp as Handicap Ramp in Floor/Pwork. 

Mark->Ramp--> Unmark (Default): Mark Unmark (Default) Ramp in Floor/Pwork. 

Mark->FAR-> Existing FAR (PDCRCONES): Mark FAR Poly as Existing FAR. 

Mark->FAR->Normal (Default) (PDCRUMFAR): Mark FAR Poly as Normal FAR. 

Mark->Carpet Area->Splitted Tenement (PDCRMSPLTT): Mark Carpet Area as Splitted 

tenement. 

Mark->Carpet Area->Slum Development->Sale: Mark Carpet Area as Sale tenement. 

Mark->Carpet Area->Slum Development->Sale: Mark Carpet Area as rehab tenement. 

Mark->Carpet Area->Normal (Default): Mark Carpet Area as Normal (Default) tenement. 

Mark->Parking->Two-stacked, three-stacked four-stacked (PDCRUMENCBL): mark parking 

as an two stacked, three stacked and four stacked 

Mark->Projection-- > 

Mark->Projection->Chhajja (PDCRMCJPROJ): Mark Projection as Chhajja. 

Mark->Projection->Loft -> (PDCRMLPROJ): Mark Projection as Loft in floor plan as well as in 

section. 

Mark->Projection->Canopy (PDCRMCBPROJ): Mark Projection as Canopy. 

Mark->Projection->Porch (PDCRMCBPROJ): Mark Projection as Porch.    

Mark->Projection->Verandah (PDCRMCPROJ): Mark Projection as a Verandah.  

Mark->Projection->Otta (PDCRMOPROJ): Mark Projection as An Otta.  

Mark->Projection->Steps (PDCRMSPROJ): Mark Projection as a Steps. 
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Mark->Existing Structure->to be demolish (Default) (PDCRMRMREXWC): Mark Existing 

structure as to be Demolish. 

Mark->Existing Structure ->To Be Retained ->Building or Substructure (PDCRMREXWD): 

Mark Existing structure as to be Retained Building or Substructure. 

Mark->SubStructure-> Electric Meter Room (PDCRMER): Mark Substructure as an Electric 

meter room. 

Mark->SubStructure-> Electric Sub-Station (PDCRSS): Mark Substructure as an Electric Sub-

Station. 

Mark->Substructure->Watchman Cabin    (PDCRMTRAN): Mark Sub Structure as a watchman 

cabin. 

Mark->Substructure->Society Office (PDCRMOR): Mark Sub Structure as a Society office. 

Mark->SubStructure->Servant Quarter (PDCRMSQ): Mark Sub Structure as a servant quarter. 

Mark->SubStructure->Sanitary Block (PDCRMSB): Mark Sub Structure as a sanitary block. 

Mark->SubStructure ->Covered Garage (PDCRMGRJ): Mark Sub Structure as a garage when 

garage is covered. 

Mark->Substructure -> Rain Water harvesting (PDCRRWH): Mark Sub Structure as a Rain 

Water harvesting  

Mark->Substructure -> A.C Plant Room (PDCRACP): Mark Sub Structure as An A.C Plant Room. 

Mark->Substructure -> A.H.U (PDCRAHU): Mark Sub Structure as A.H.U. 

Mark->Substructure -> Swimming Pool (PDCRMSP): Mark Sub Structure as a Swimming Pool  

Mark->Substructure -> Septic Tank/Soak pit (PDCRST): Mark Sub Structure as a Septic 

Tank/Soak pit   

Mark->Substructure ->Pump House-> (PDCRMPR): Mark Sub Structure as a Pump House. 

Mark->Substructure ->Effluent Treatment Plant/ STP (PDCRMETP): Mark Sub Structure as An 

Effluent Treatment Plant/ STP. 

Mark->Substructure ->Dish Antenna room (PDCRMSPT): Mark Sub Structure as a Dish 

Antenna room. 

Mark->Substructure -> Well (PDCRMSPT): Mark Sub Structure as a Well. 

Mark->Substructure ->Telephone Installation room (PDCRMSPT): Mark Sub Structure as a 

Telephone Installation room. 

Mark->Substructure -> Entrance gate (PDCRMSPT): Mark Sub Structure as an Entrance gate. 
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Mark->Substructure -> Fitness Centre (PDCRMSFC): Mark Sub Structure as a Fitness Centre. 

Mark->Substructure -> Suction Tank: Mark Sub Structure as a Suction Tank. 

Mark->Substructure -> pavilion (PDCRMSPL): Mark Sub Structure as a Pavilion. 

Mark->Substructure -> Gymnasium (PDCRMSGM): Mark Sub Structure as a Gymnasium. 

Mark->Substructure -> Club House (PDCRMSCH): Mark Sub Structure as a Club House. 

Mark->Substructure -> Dustbin (PDCRMSDB): Mark Sub Structure as a Dustbin. 

Mark->Substructure -> Milk/Telephone Booth (PDCRMSMTB): Mark Sub Structure as a 

Milk/telephone Booth. 

Mark->Substructure -> Letter Box (PDCRMSLB): Mark Sub Structure as a Letter Box.  

 Mark->Substructure -> Chimney (PDCRMSCM): Mark Sub Structure as a Chimney. 

Mark->Substructure -> Storage (PDCRMSSG): Mark Sub Structure as a Storage. 

Mark->Substructure -> Godown (PDCRMSGD): Mark Sub Structure as a Godown. 

Mark->Margin (PDCRMRGN): Use this command to define or mark the front, sides and rear 

margins of the Plot Boundary. 

 

Insert entities 
Insert->Parking-> Car (PDCRICP) -> Use this command to insert car-parking poly of at 

selected point. 

Insert-> Parking-> Scooter (PDCRISP) ->Use this command to insert Scooter parking poly at 

selected point. 

Insert-> Parking-> Cycle (PDCRICY) ->Use this command to insert Cycle parking poly at 

selected point. 

Insert->Parking-> Loading/Unloading (PDCRIVP) -> Use this parking -> Loading/Unloading. 
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Insert->Door (PDCRIDRNAM): Use this command to insert door poly at selected point and with 

specified size given by user. As soon as you use this command, the following Dialog appears.   

 

 
Insert->Window (PDCRIWNDNAM): Use this command to insert window poly at selected 

point and with specified size given by user. 

 

 

 

Insert->Common Reference Circle (PDCRIWC): Use this command to insert Common 

reference circle. Insert these circles in all the floor plans as well as in proposed work at the 

common place (e.g. Lift or Stair) of all the floors. 

Insert->Direction Reference Circle (PDCRIWC): Use this command to insert direction 

reference circle. Insert these circles in all the floor plans as well as in proposed work at the 

common place (e.g. Lift or Stair) of all the floors. 

Insert->Tree: Use this command to insert Tree. Insert Tree in Plot Poly. 

Insert->North Direction: Use this command to insert North Direction. Insert it Plot Poly. 

Insert->Staircase UP/DN Direction: Use this command to insert UP/DN Direction in Staircase. 
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Assign Name 
There are few naming conventions required by AutoDCR, for which PreDCR provides the 

following tools: 

Assign Name->Building and proposed works (PDCRBLDPWNL): Use this command to give 

name for building poly and its associated proposed works. 

 
Assign Name->Tank (PDCRTNKNAM): Use this command to give name for Tank poly and its 

corresponding tanks. 

 

Fill in the dialog and select the tank poly drawn in plan and the same drawn in section 

Assign Name->Room (PDCRASRUN): Use this command to give different names for Room poly. 
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Assign Name->Floor Name (PDCRASFLRNAM): Use this command for assigning name to a 

floor poly and its corresponding floor in section poly in section. 

 
 

Tools  
All/Remover Tool Tip (PDCRTOOLTIP): 
This command will activate the tool tips for PreDCR layers. 

Show Only DCR Layers: 

All PreDCR layers (PDCRSPL):  
This command will turn off all the layers in the drawing except PreDCR layers.  
Building level layer (PDCRSBL): 
 This command will turn on all the building plan level layers in the drawing. 

Layout level layer (PDCRSLL): This command will turn on all the Layout plan level layers in the 

drawing. 
Show all layers (PDCRSAL):  
This command will turn on all layers in the drawing. 
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Calculate Deducted Area (PDCRCDA):  
This command will compute the area of closed polygon after deducting closed polygons found 

inside. 

           
 
Calculate Total Area (PDCRCTA):  
This command will compute the total area of all selected closed polygons. 

 
 
Get All Inside Poly (PDCRFIP):  
This command will highlight all polygons, which found exactly inside selected polygon under 

test. 
Get All Overlapping Poly (PDCRGOP):  
This command will highlight all polygons, which are overlapping with selected polygon under 

test. 
Get All Intersecting Poly (PDCRGIP):  
This command will highlight all polygons, which are intersecting with selected polygon under 

test. 
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Find Open Entities (PDCRFNDO): Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC): Highlight closed entities on PreDCR layer. 

 

Spelling check (_spell): This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ): This command zoom & highlight object of a given handle. 

 

Shortest distance (PDCRFSD): This command will find the shortest distance between two 

entities. 

 

Set Default ACAD Version (PDCRSDA): 

 

 

PREDCR SHORT-CUT COMMANDS 
Layer name Description 

 

Naming 

Convention 

short 

command 

_Amenity Draw Amenity space as a closed 

polyline, which is reserve for 

utilities, services and 

conveniences. 

 AMN 

_ArchProj This layer is used to represent 

various Architectural Projections 

in your Plan. Draw a closed 

Polyline for Architectural 

Projections. And mark it using 

Mark->Projection from PreDCR 

menu, according to requirements. 

Canopy/porch will come in Plot 

Boundary & other projections 

 

Mark -> Projections 

-> Chhajja 

 

AP 
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will come with floor plans. 

_Balcony Draw a balcony as a closed 

polyline which is a horizontal 

projection including parapet to 

serve as a sitting out place. Name 

of balcony must be inside and on 

_Balcony layer. 

 

If Balcony is 

Enclosed Than 

Mark -> Balcony -> 

Enclosed Balcony 

 

BL 

_Building Building is used to group all floor 

plans of the same building.   Draw 

a closed poly enclosing all the 

floor plans and section of the 

same building on _Building layer. 

Note: As written above, 

dimension or area of this building 

poly has no meaning in AutoDCR. 

This is just a logical group of all 

floors of the same building. If the 

building plans of multiple PWorks 

or wings are same, then building 

name shall be as given aside. 

 

Naming 

Convention will be  

provided by 

Tool>Assign Name 

A (Bldg. Name) 

inside Bldg.Poly & 

A-1 (Bldg. Name) 

inside Pwork Poly 

BLD 

_Carpetarea Draw carpet area as a closed 

polyline which is a net usable 

floor area within a building 

excluding that covered by the 

walls or any other areas 

specifically exempted from floor 

space index computation in these 

regulations. 

If Carpetarea is 

Splitted – 

Tenement. 

Mark-> Carpetarea-

> normal (default) 

 

CPT 
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 _Chowk Draw a Chowk as a closed 

polyline, which is an enclosed 

space permanently open to the 

sky within a building at any level. 

From Chowk we take ventilation 

for habitual rooms 

 CWK 

_CommFAR Draw a CommFAR as a closed 

polyline, which is the area, 

covered by a building on all the 

floors. This FAR polyline mainly 

used for commercial use bldg. 

No need to give 

name on this layer. 

CMFS 

_CompoundWall Closed polyline of compound wall 

to be drawn on this layer 

overlapping Plot Boundary. 

 

1.5m high 

compound wall 

CW 

_Door  Door is a closed Polyline, which is 

drawn on “_Door” layer also, you 

can insert a particular size poly 

for Door using Insert->Door from 

PreDCR menu. 

 

Insert-> Door 

DR 

_Elect line 

 

 

 

 

Electric line will be present in the 

layout plan and shall pass 

through Plot Boundary entity as a 

non-closed polyline. 

Name electric line shall start with 

its voltage capacity and text 

insertion point shall lie on its 

polyline. 

33 KV High Tension 

Line 

L1 

_Elevation Draw Elevation on this layer and 

must be present in Building Poly. 

  

_EWS Draw EWS are on this layer.   
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_ExStructure Draw an Exstructure as a closed 

polyline, which is a building, or 

structure existing authorized 

before the commencement of 

these regulation and mark it 

using Mark -> Existing structure 

as 'To be demolished' or 'To be 

retained’. 

Mark-> Existing 

Structure-> To be 

Demolished    OR   

To be Retained       

ES 

_Floor Floor poly should be drawn as a 

closed Polyline with Text on same 

Layer. This is just a logical Group 

of all floor Entities. 

Floor Name: Floor Plan will be 

automatically link with Section by 

matching the Floor Name. Hence 

all names to be given using 

<Assign Name> function 

Naming 

Convention will be  

Provided by 

Tool>Assign 

Name>Floor name. 

Name of  floor 

should be in given 

format: 

TYPICAL-1,4 

FLOOR PLAN 

TYPICAL-1-5 

FLOOR PLAN 

TYPICAL-2&3 

FLOOR PLAN 

Ground Floor Plan. 

FLR 

_FloorInSection  Description: - Draw a Floor 
Inspection as a closed polyline 
which is the height of that 
floor (slab top to slab top) 
This poly only used for 
checking floor height. For 
assigning, the name of 
FloorInSection then used 
Assigned name option for 
PreDCR tool menu. 

 SECF 
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1.   Name of each floor 
section will be same as of 
floor in plan. 

2.   For one typical floor plan 
multiple floor section will 
be there. 

For e.g. for one typical floor 
plan for 1-3 floors there will 
three sections shall be drawn 
with name "First Floor Plan", 
"Second Floor Plan" and 
"Third Floor Plan" 
respectively. 

_GroundLevel  The Ground level line should be 
drawn as an open polyline in the 
section poly. 
Prop.Ht. will be considered from 
GroundLvl Polyline 

 

No need to give 

name on this layer. 

  

GL  

_IndFAR Draw a closed FAR Polyline, 

which is used as an Industrial 

Purpose. 

No need to give 

Name on this layer.  

IFAR  

_IndivSubPlot  For plotting layout draw 

individual subplots having unique 

text on _IndivSubPlot' layer inside             

main plot.  

 R3 

_InternalRoad 

 

Draw each Internal Road as a 

closed Polyline with Centre Line 

(Ltype-CentreLine) & single text 

inside it. 

 

7.50 m wd. Internal 

Road 

R2 

_LiftWell 

 

Draw a Lift as a closed polyline 

which is a mechanically guided 

car, platform or transport for 

persons and materials between 

two or more levels in a vertical or 

substantially vertical direction 

Naming 

Convention will be  

provided by 

Tool<Mark>Lift 

 

If fire lift is 

LFT 
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 Fire Lift means a special lift 

designed for the use of fire 

service personnel in the event of 

fire or other emergency. 

provided, then use 

the marking of " 

Fire >Hydraulic  or     

Unmark (default ) 

LIG Draw EWS are on this layer.   

_Location plan 

 

Location plans if any to be drawn 

on this layer. This is only for 

reference. AutoDCR does no 

verifications for this layer so not 

compulsory. 

 LCP 

_MainPlot 

  

Description: - Draw a MainPlot 

poly as a closed polyline, which is 

a parcel or piece of land enclosed 

by definite boundaries. A 

MainPlot will contain all 

Proposed Works (buildings, 

wings), open space, Internal 

Roads, Parking etc. The overall 

MainPlot Entity represent a Plan, 

AutoDCR refer it as "Layout 

Plan". 

 PLT 

_MainRoad 

 

Draw Main Road as a closed Poly 

with Text, which should be 

abutting with the Plot Boundary 

closed Poly. 

(Note: Road width must be 

written at the starting of Text) 

 

24.00 m wd. Main 

Road 

R1 
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_Margin line Margin Polylines will be created 

by PreDCR by using Tool 

"Mark>Margins” (User need not 

do anything on this layer.) 

 L3 

_Net Plot No need to draw NETPLOT. This 

layer is not provided for PreDCR 

users. 

No need to give 

name on this layer. 

 

NPLT 

 

_NotInPossession  Main Plot area which is not in 

possession or which is not in 

proposal to be drawn as a closed 

polyline on this layer.  

 NIP  

_Parking  Draw a closed Polyline for 

Parking on “_Parking” Layer. You 

can also use Insert function to 

insert desired Parking Poly in 

your drawing. 
 

Insert-> Parking-

>Car/Scooter/ 

Transport Vehicle/ 

Visitor Parking 

(Car) OR 

Loading/unloading 

 

 PK 

_Passage 

  

Draw a closed polyline on 

“_Passage” Layer to represent 

passage with Centre Line (Ltype-

CentreLine) & single text inside it. 

(Note: If Premium for Passage is 

going to be Paid, Passage should 

be marked by using Tool "Mark" 

Mark > Passage > 

covered Passage.> 

Free from FAR or 

Taken in FAR. 

Mark > Passage > 

Open Corridor 

Mark > Passage > 

Fire Escape 

Passage. 

PAS  

Plot Surrounding- 

Details 

Show abutting details on 

“_PlotSurroundingDetails” layer 

which is around your property 

where site is going to propose. 
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For ex. Plot no, road width, etc. 

_Podium 

 

Draw a closed polyline on 

“Podium“ to represent Podium. It 

should be shown in the layout 

and not in floor plans. 

 

 

POD  

_PrintAdditionalDetail  Description: - Any additional 
details apart from details 
provided on all other PreDCR 
layers can be drawn on this layer. 
These details may not be 
necessary for actual scrutiny 
process but can be used as 
additional supporting 
information. 

 ADET  

_PropWork Pwork is a building profile and 

shall be drawn inside Plot 

Boundary. Draw a closed polyline 

for Proposed Work on 

“_PropWork” Layer. 

Tools > Assign 

Name >  

Building and 

PropWork.  

PW  

_Ramp 

  

 Draw a Ramp as a closed polyline 

with Centerline (L-type-Centre) & 

Text inside it in Plan. 

10.0m long 1.5m 

high Ramp 

 

RP 

_RecreationalGnd  Description: - Draw Open space 

as closed polyline reserved as 

recreational space on this layer. 

With text on same layer. 

 

 

OPS 

_RefugeArea 

 

A closed polyline with Text 

around the refuge area should be 

drawn on same Layer. 

Refuge area should be outside 

 RFG 
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overlapped with FAR (ResiFAR, 

CommFAR) poly. 

_RefugeChute Draw RefugeChute area on this 

layer. 

  

_ResiFAR Draw a ResiFAR as a closed 

polyline, which is the area, 

covered by a building on all the 

floors. This FAR polyline only 

used for residential use Bldg or 

floor. 

 

No need to give 

name on this layer. 

MFS 

_RightOfWay  Description: - Draw a closed 

polyline on “_RightOfWay” to 

represent a Right Of way and text 

inside it representing its width. 

Layer should be inside or 

intersecting with main Plot poly.  

 ROW  

_RoadWidening Road Acquisition/Road Widening 

area shall be drawn as a closed 

Polyline with Text on same layer 

inside Main Plot Entity. Margin 

will be generated & checked from 

RoadWidening Poly by AutoDCR 

software. 

 R5 

_Room A closed polyline for each room 

with its text inside should draw 

on this layer. Text should be given 

using <Assign Name> function 

Assign Name > 

Room 

RU 

_Section Section poly should be drawn as a 

closed Polyline with Text on same 

Layer. It is used to group all 

 SEC 
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Sectional detail like 

FloorInSection, Plinth, Stair cabin, 

Tank etc. 

(This is just a logical Group of 

Sectional Entity).  

(Note: Area or size of Floor 

doesn't have any meaning in 

AutoDCR) 

_Sewageline  Description: - Drain/Sewage Line: 

- Sewage line shall be drawn as an 

open polyline on this layer.  

 L5  

_Skyway Draw Skyway area on this layer.   

_SpecialUseFAR A closed poly represents another 
than Residential, commercial or 
Industrial use FAR or Floor FAR. 
It will cover whole area, which is 
considered in FAR Area per Floor. 

 SUF 

_StairCase Total Staircase area should be 

drawn as a closed polyline with 

text inside it. This Main Stair Poly 

should contain Intermediate 

Landing, Floor Landing & Each 

Tread as an open polyline. 

Intermediate & Floor Landing 

Poly can be Marked by PreDCR 

Tool "Mark>Staircase>Int. or 

Floor Landing" (Note: If Premium 

for Staircase is going to be Paid, 

Staircase should be marked by 

using Tool "Mark>Staircase>Free 

from FAR" 

Mark-> Stair Case-> 

No. of flight >3 

Flight or 4 Flight 

Fire Escape 

Staircase OR 

Fab/Spiral Stair 

 Staircase  and 

Common Stair 

Mark-> Staircase 

Landing-> Flight 

Width, 

Intermediate & 

Floor Landing. 

STR 
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_SubStructure Substructures, which are allowed 

in Margins or Layout & Free from 

FAR, should be drawn as a closed 

polyline with text inside it. 

Name of the 

SubStructure can 

be assigned from 

Mark>SubStructure  

SSTR 

_SubWay Draw Subway on this layer.   

_Tank Tank clear size should be drawn 

as a closed Polyline with Text on 

this Layer in Floor Plan or Plot 

Boundary as well as Section with 

same Text. 

(Note: It should be in proper 

Naming convention, which is 

Provide by PreDCR by using Tool. 

Assign Name>Tank   TNK 

_Terrace Closed polylines around the 

terraces to be drawn on this layer. 

If the terrace is used commonly 

by all tenements mark it as 

Common Terrace else, it will be 

treated as Individual by default. 

 TER 

_tree   Description: - Insert Tree form 
Insert option. It must present 
inside of MainPlot. 

Insert-> tree   

_VentilationShaft  Description: - Draw 
VentilationShaft/duct area as a 
closed Polyline with Text. Inside 
FAR Area on _ArtiVentiShaft 
Layer. Only those shafts from 
which ventilation for habitable 
room is not taken should be 
drawn on this layer. 

 VS   

_Void If the space is not Chowk, then it 

can be void. All ducts (where 

ventilation is not taken) and double 

 VD 
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height rooms can be drawn in void 

layer. 

_Waterline Draw an open polyline on 

“_WaterLine” to represent water 

lines. 

 L4 

_Window Draw a closed polyline on 

_Window” Layer to represent 

window. You can also use Insert 

tool to insert window poly for 

particular size. 

Insert > window WND 

 

 

Specifications to be followed-  

The drawing entities should be drawn on Automatic layers created by using PreDCR. 

Plot Boundary layout, detailed floor plan and building section for all the floors should be there 

in one AutoCAD drawing file.   

All building items like proposed Plot Boundary, proposed work, proposed parking etc. must be 

drawn using closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, Dead Wall and Ground level.) 

Building Sub-Items must be exactly inside of outer closed polyline as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container 

entity. For example, Parking or Open Space poly must be exactly inside the main Plot Boundary 

poly. Tools are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the 
same layer & inside the entity poly. As far as possible, this name should be unique. If name not 
found, then AutoDCR will generate the name automatically. Naming Conventions should be 
followed properly. 
e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 
Living, Kitchen, and Bedroom. Etc. Floor Name: GROUND FLOOR; TYPICAL FLOOR 1, 2 & 5-8; 
TERRACE FLOOR. Floor Items: Room Names should be given properly without using 
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abbreviations so the software can identify perfect entity. This can be done by Assign name 
facility provided by the software. 
User shall use only following kind of entities for Building Items: -  
LWPOLYLINE / TEXT / MTEXT 
If in a plan two proposed work are mirrored in that case user should provide two separate 
building plans for each proposed work. 

 

 

 

 
Sample cases 

 

Residential Bldg (Row house) 
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Residential bldg. (Single Detached with two buildings) 
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Commercial building 

 
 

 Industrial Building 
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Special building (School bldg.) 

 

Meaning of various PreDCR Messages 
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“Entity contain more than one text"  

      It means Entity on this layer contain more than one text. So, remove the extra text. PreDCR 

need only one text for one entity. 

 

"Entity not contain any text"  

       It means this entity not having any name/text, so give the name to this   entity on this layer 

 

"Polyline is not in a proper format"  

        It means Highlighted polyline not drawn properly. So, redraw that polyline & check the 

properties of that polyline. 

"Entity is not closed"  

       It means the highlighted entities not a closed polyline so close it by using 'pedit' command. 

 

"Entity is supposed to inside one of the following entities"  

       It means this highlighted entity should be present inside the one of the entities present in 

the given list“ 

 

"Entity is supposed to touching one of the following entities"  

      It means this highlighted entity is supposed to be touched one of the entities in given list 

 

"Entity should be outside overlapped with following entities“ 

      It means the highlighted entity should be outside overlapped with one of the entities in the 

given list. 

“Entity must contain one of following entities“ 

      It means any one layer should be present inside in this entity which is listed. 

 

Following sub entities are not found inside:  

     Direction Ref Point on layer _Floor, 

    Type: BLOCK, Color: By Layer Status: 

    Common Point on layer _ResiFAR, 

    Type: BLOCK, Color: By Layer Status: 
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    It means insert the direction reference circles in side of those entities. 

"The corresponding Building not found with same name"  

     It means that proposed work not having building with same name. So assigned that building 

with having same name of proposed work. 

"Mark Substructures using PreDCR mark Substructure tool"   

        It means mark the substructure by using mark -> Substructure menu.  Do not type 

substructure name manually. 

 

"The lift machine room not found in building"  

        It means lift machine room having name not same in Plan & in section. 

 

"The lift poly is not supposed to be touch lift machine room"  

        It means Lift machine room should be touched to lift poly in the section. 

 

 ‘Invalid objects, Please Try again"  

        It means if user marking balcony as an enclosed   but selecting layer of terrace then this 

message is getting. If selected entity is incorrect then invalid objects message are showing. So, 

select correct layer for particular of that layer marking only 

"Section not found"  

      It means If all the floor plans are drawn but one of them in section floor are missing to 

converting floor in section layer then this message are getting. So, draw all the floor plans with 

floor in sections. 

 

"The corresponding entities not found in section"  

      It means that listed entities are not present in the section so show that entities in the section. 

 

"The corresponding entities not found in floor"  

      It means that listed entities are not present in the floor so show that entities in the floor plan. 

 

“Two Tanks should not have same Name” 

      It means that two tanks not having a same name. So, assigned two tanks by using Assigned 
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name PreDCR menu. 
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